quote
quote
quote
quote
quote
icons 18

WHICH VERSION OF .NET SHOULD YOU BE USING ON YOUR RIGHTFAX SERVER?

If an upgrade of .NET is required on your RightFax server, we recommend performing the upgrade in a test environment, and testing key
functionality within the environment to ensure no problems arise. Newer versions of .NET are meant to be backwards compatible with applications that
use older versions of the framework. Even so, updates to the .NET framework can cause unforeseen issues, and therefore we typically recommend
running the version of .NET on your server that was used to compile your version of RightFax.

.NET Version RightFax Versions
1.1 9.3 Base through 9.3 FP2
2.0 9.3 FP2 through 9.3 FP2 SR6
3.5 9.4 All Versions
4.0 10.0 All Versions
10.5 Base through 10.5 FP1 SR5
4.5 10.5 FP1 SR5
10.6 All Versions

RightFax equires the .NET framework for various functions. Some modules where developed ith .NET:

  • RightFax Remoting Service
  • RightFax Licensing Service
  • RightFax Sync Module (formerly Capasync)
  • RightFax Conversion Engine
  • RightFax EWS Connector
  • RightFax Exchange Connector

Other modules use .NET libraries for various functions, but ae not included in this list.

Please visit this Microsoft article or more information about general .NET version compatibility. If any problems rise when upgrading the .NET framework on your RightFax server, please contact s at 866-730-1700 or email This email address is being protected from spambots. You need JavaScript enabled to view it. for information.